diff options
| author | fukachan <fukachan> | 2001-10-08 06:11:07 +0000 |
|---|---|---|
| committer | fukachan <fukachan> | 2001-10-08 06:11:07 +0000 |
| commit | b109ed99bbf299b5f15cf86d21d35de9666a9b8d (patch) | |
| tree | 81cf43adf58a9e788c99e86df3c603a1591f2a6c | |
| parent | 72b9fdcd785f7657f694dac0380da169d0f05bf9 (diff) | |
| download | fml8-b109ed99bbf299b5f15cf86d21d35de9666a9b8d.tar.gz fml8-b109ed99bbf299b5f15cf86d21d35de9666a9b8d.tar.bz2 fml8-b109ed99bbf299b5f15cf86d21d35de9666a9b8d.zip | |
make index.html to show index
| -rwxr-xr-x | Documentation/en/rfc/.track_relation.pl | 111 | ||||
| -rw-r--r-- | Documentation/en/rfc/Makefile | 9 | ||||
| -rw-r--r-- | Documentation/en/rfc/index.html | 417 |
3 files changed, 514 insertions, 23 deletions
diff --git a/Documentation/en/rfc/.track_relation.pl b/Documentation/en/rfc/.track_relation.pl index 143c3cd4..88de8c4d 100755 --- a/Documentation/en/rfc/.track_relation.pl +++ b/Documentation/en/rfc/.track_relation.pl @@ -5,7 +5,7 @@ # All rights reserved. This program is free software; you can # redistribute it and/or modify it under the same terms as Perl itself. # -# $FML: @template.pm,v 1.1 2001/08/07 12:23:48 fukachan Exp $ +# $FML: .track_relation.pl,v 1.1 2001/10/08 05:34:32 fukachan Exp $ # use strict; @@ -19,20 +19,22 @@ my $debug = $ENV{'debug'} ? 1 : 0; # %rfc_prev double link list # %rfc_next double link list my (%rfc_exists, %rfc, %rfc_prev, %rfc_next); -my ($r); +my ($result) = {}; -check_rfc_here(); -read_rfc_index(); # set up %rfc -analyze( $r ); -show( $r ); +check_rfc_here( \%rfc_exists ); +read_rfc_index( "./rfc-index.txt", \%rfc ); +analyze( $result ); +show( $result ); sub check_rfc_here { + my ($rfc_exists) = @_; + for (<rfc*txt>) { if (/RFC(\d+)/i) { my $x = sprintf("RFC%04d", $1); - $rfc_exists{$x} = $x; + $rfc_exists->{$x} = $x; } } } @@ -40,8 +42,10 @@ sub check_rfc_here sub read_rfc_index { + my ($f, $rfc) = @_; + use FileHandle; - my $fh = new FileHandle "rfc-index.txt"; + my $fh = new FileHandle $f; my $cur = undef; if (defined $fh) { @@ -51,7 +55,7 @@ sub read_rfc_index } if (defined $cur) { - $rfc{ "RFC$cur" } .= $_; + $rfc->{ "RFC$cur" } .= $_; } } close($fh); @@ -126,11 +130,10 @@ sub _combine sub _sort_links { - my ($a, $b) = @_; - $a =~ /RFC/; - $b =~ /RFC/; - - $a <=> $b; + my ($ra, $rb) = ($a, $b); + $ra =~ s/RFC//i; + $rb =~ s/RFC//i; + $rb <=> $ra; } @@ -173,16 +176,25 @@ sub _analyze_links } +sub _rfc2filename +{ + my ($fn) = @_; + + $fn =~ s/RFC/rfc/; + $fn =~ s/0(\d{3})/$1/; + $fn .= ".txt"; + + return $fn; +} + + sub _check_exists { my ($buf) = @_; for (split(/\s+/, $buf)) { if (/rfc\d+/i) { - my $fn = $_; - $fn =~ s/RFC/rfc/; - $fn =~ s/0(\d{3})/$1/; - $fn .= ".txt"; + my $fn = _rfc2filename($_); unless (-f $fn) { print "no $fn\n"; if (-d "source") { @@ -207,18 +219,71 @@ sub _clean_up } + +=head2 C<show( $result_hash )> + +show rfc relation from the given $result_hash. +$result_hash contains the following hash pair. + + RFC-LAST => RFC-A RFC-B RFC-C ... RFC-LAST + +=cut + + sub show { my ($r) = @_; - my ($k, $v); - while (($k, $v) = each %$r) { - my @r = split(/\s+/, $v); - my $rv = _remove_dup( \@r ); - print "$k => @$rv\n"; + print "<UL>\n"; + + for my $last_rfc (sort _sort_links keys %$r) { + my $v = $r-> { $last_rfc }; + my @r = sort _sort_links split(/\s+/, $v); + + my $links = _remove_dup( \@r ); + + print "<LI>\n"; + print _href( $last_rfc ), "\n"; + print _who_i_am( $last_rfc ); + + my $buf; + for my $link (@$links) { + next if $link eq $last_rfc; + if ($link =~ /rfc\d+/i) { + $buf .= "<A HREF=\"#$link\">$link</A>\n"; + } + } + + print "<BR> Updates:\n"; + print $buf ? $buf : "none"; + print "<BR>\n"; } + print "</UL>\n"; +} + + +sub _href +{ + my ($rfc) = @_; + my $fn = _rfc2filename($rfc); + return "<A NAME=\"$rfc\" HREF=\"$fn\">$rfc</A>"; } + +sub _who_i_am +{ + my ($rfc) = @_; + my $buf = $rfc{ $rfc }; + + $buf =~ s/^\d+\s//g; + $buf =~ s/\n/ /g; + + if ($buf =~ /^(.*?)\./) { + return "\"$1\"\n"; + } +} + + 1; diff --git a/Documentation/en/rfc/Makefile b/Documentation/en/rfc/Makefile new file mode 100644 index 00000000..1852a613 --- /dev/null +++ b/Documentation/en/rfc/Makefile @@ -0,0 +1,9 @@ +# +# $FML$ +# + +PERL = perl + +index.html: rfc*txt + $(PERL) .track_relation.pl > index.html.new + mv index.html.new index.html diff --git a/Documentation/en/rfc/index.html b/Documentation/en/rfc/index.html new file mode 100644 index 00000000..2a1e298f --- /dev/null +++ b/Documentation/en/rfc/index.html @@ -0,0 +1,417 @@ +<UL> +<LI> +<A NAME="RFC3090" HREF="rfc3090.txt">RFC3090</A> +"DNS Security Extension Clarification on Zone Status" +<BR> Updates: +<A HREF="#RFC3008">RFC3008</A> +<A HREF="#RFC3007">RFC3007</A> +<A HREF="#RFC2931">RFC2931</A> +<A HREF="#RFC2535">RFC2535</A> +<A HREF="#RFC2137">RFC2137</A> +<A HREF="#RFC2065">RFC2065</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<BR> +<LI> +<A NAME="RFC3023" HREF="rfc3023.txt">RFC3023</A> +"XML Media Types" +<BR> Updates: +<A HREF="#RFC2376">RFC2376</A> +<A HREF="#RFC2048">RFC2048</A> +<A HREF="#RFC1590">RFC1590</A> +<A HREF="#RFC1522">RFC1522</A> +<A HREF="#RFC1521">RFC1521</A> +<A HREF="#RFC1342">RFC1342</A> +<A HREF="#RFC1341">RFC1341</A> +<BR> +<LI> +<A NAME="RFC3008" HREF="rfc3008.txt">RFC3008</A> +"Domain Name System Security (DNSSEC) Signing Authority" +<BR> Updates: +<A HREF="#RFC2535">RFC2535</A> +<A HREF="#RFC2065">RFC2065</A> +<BR> +<LI> +<A NAME="RFC3007" HREF="rfc3007.txt">RFC3007</A> +"Secure Domain Name System (DNS) Dynamic Update" +<BR> Updates: +<A HREF="#RFC2137">RFC2137</A> +<A HREF="#RFC2136">RFC2136</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC2931" HREF="rfc2931.txt">RFC2931</A> +"DNS Request and Transaction Signatures ( SIG(0)s)" +<BR> Updates: +<A HREF="#RFC2535">RFC2535</A> +<A HREF="#RFC2065">RFC2065</A> +<BR> +<LI> +<A NAME="RFC2919" HREF="rfc2919.txt">RFC2919</A> +"List-Id: A Structured Field and Namespace for the Identification of Mailing Lists" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC2870" HREF="rfc2870.txt">RFC2870</A> +"Root Name Server Operational Requirements" +<BR> Updates: +<A HREF="#RFC2010">RFC2010</A> +<BR> +<LI> +<A NAME="RFC2852" HREF="rfc2852.txt">RFC2852</A> +"Deliver By SMTP Service Extension" +<BR> Updates: +<A HREF="#RFC1894">RFC1894</A> +<BR> +<LI> +<A NAME="RFC2845" HREF="rfc2845.txt">RFC2845</A> +"Secret Key Transaction Authentication for DNS (TSIG)" +<BR> Updates: +<A HREF="#RFC2535">RFC2535</A> +<A HREF="#RFC2308">RFC2308</A> +<A HREF="#RFC2181">RFC2181</A> +<A HREF="#RFC2137">RFC2137</A> +<A HREF="#RFC2136">RFC2136</A> +<A HREF="#RFC2065">RFC2065</A> +<A HREF="#RFC1996">RFC1996</A> +<A HREF="#RFC1995">RFC1995</A> +<A HREF="#RFC1982">RFC1982</A> +<A HREF="#RFC1876">RFC1876</A> +<A HREF="#RFC1348">RFC1348</A> +<A HREF="#RFC1183">RFC1183</A> +<A HREF="#RFC1123">RFC1123</A> +<A HREF="#RFC1101">RFC1101</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC2822" HREF="rfc2822.txt">RFC2822</A> +"Internet Message Format" +<BR> Updates: +<A HREF="#RFC0822">RFC0822</A> +<A HREF="#RFC0733">RFC0733</A> +<A HREF="#RFC0724">RFC0724</A> +<BR> +<LI> +<A NAME="RFC2821" HREF="rfc2821.txt">RFC2821</A> +"Simple Mail Transfer Protocol" +<BR> Updates: +<A HREF="#RFC1869">RFC1869</A> +<A HREF="#RFC1651">RFC1651</A> +<A HREF="#RFC1425">RFC1425</A> +<A HREF="#RFC0974">RFC0974</A> +<A HREF="#RFC0821">RFC0821</A> +<A HREF="#RFC0788">RFC0788</A> +<A HREF="#RFC0780">RFC0780</A> +<BR> +<LI> +<A NAME="RFC2646" HREF="rfc2646.txt">RFC2646</A> +"The Text/Plain Format Parameter" +<BR> Updates: +<A HREF="#RFC2046">RFC2046</A> +<A HREF="#RFC1590">RFC1590</A> +<A HREF="#RFC1522">RFC1522</A> +<A HREF="#RFC1521">RFC1521</A> +<A HREF="#RFC1342">RFC1342</A> +<A HREF="#RFC1341">RFC1341</A> +<BR> +<LI> +<A NAME="RFC2554" HREF="rfc2554.txt">RFC2554</A> +"SMTP Service Extension for Authentication" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC2535" HREF="rfc2535.txt">RFC2535</A> +"Domain Name System Security Extensions" +<BR> Updates: +<A HREF="#RFC2308">RFC2308</A> +<A HREF="#RFC2181">RFC2181</A> +<A HREF="#RFC2065">RFC2065</A> +<A HREF="#RFC1982">RFC1982</A> +<A HREF="#RFC1876">RFC1876</A> +<A HREF="#RFC1348">RFC1348</A> +<A HREF="#RFC1183">RFC1183</A> +<A HREF="#RFC1123">RFC1123</A> +<A HREF="#RFC1101">RFC1101</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<A HREF="#RFC0822">RFC0822</A> +<BR> +<LI> +<A NAME="RFC2487" HREF="rfc2487.txt">RFC2487</A> +"SMTP Service Extension for Secure SMTP over TLS" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC2476" HREF="rfc2476.txt">RFC2476</A> +"Message Submission" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC2308" HREF="rfc2308.txt">RFC2308</A> +"Negative Caching of DNS Queries (DNS NCACHE)" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC2254" HREF="rfc2254.txt">RFC2254</A> +"The String Representation of LDAP Search Filters" +<BR> Updates: +<A HREF="#RFC1960">RFC1960</A> +<A HREF="#RFC1558">RFC1558</A> +<BR> +<LI> +<A NAME="RFC2231" HREF="rfc2231.txt">RFC2231</A> +"MIME Parameter Value and Encoded Word Extensions: Character Sets, Languages, and Continuations" +<BR> Updates: +<A HREF="#RFC2184">RFC2184</A> +<A HREF="#RFC2183">RFC2183</A> +<A HREF="#RFC2047">RFC2047</A> +<A HREF="#RFC2045">RFC2045</A> +<A HREF="#RFC1806">RFC1806</A> +<A HREF="#RFC1590">RFC1590</A> +<A HREF="#RFC1522">RFC1522</A> +<A HREF="#RFC1521">RFC1521</A> +<A HREF="#RFC1342">RFC1342</A> +<A HREF="#RFC1341">RFC1341</A> +<BR> +<LI> +<A NAME="RFC2183" HREF="rfc2183.txt">RFC2183</A> +"Communicating Presentation Information in Internet Messages: The Content-Disposition Header Field" +<BR> Updates: +<A HREF="#RFC1806">RFC1806</A> +<BR> +<LI> +<A NAME="RFC2181" HREF="rfc2181.txt">RFC2181</A> +"Clarifications to the DNS Specification" +<BR> Updates: +<A HREF="#RFC1123">RFC1123</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0822">RFC0822</A> +<A HREF="#RFC0733">RFC0733</A> +<BR> +<LI> +<A NAME="RFC2049" HREF="rfc2049.txt">RFC2049</A> +"Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and Examples" +<BR> Updates: +<A HREF="#RFC2048">RFC2048</A> +<A HREF="#RFC2047">RFC2047</A> +<A HREF="#RFC2046">RFC2046</A> +<A HREF="#RFC2045">RFC2045</A> +<A HREF="#RFC1590">RFC1590</A> +<A HREF="#RFC1522">RFC1522</A> +<A HREF="#RFC1521">RFC1521</A> +<A HREF="#RFC1342">RFC1342</A> +<A HREF="#RFC1341">RFC1341</A> +<BR> +<LI> +<A NAME="RFC2034" HREF="rfc2034.txt">RFC2034</A> +"SMTP Service Extension for Returning Enhanced Error Codes" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC1996" HREF="rfc1996.txt">RFC1996</A> +"A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY)" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1995" HREF="rfc1995.txt">RFC1995</A> +"Incremental Zone Transfer in DNS" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1985" HREF="rfc1985.txt">RFC1985</A> +"SMTP Service Extension for Remote Message Queue Starting" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC1982" HREF="rfc1982.txt">RFC1982</A> +"Serial Number Arithmetic" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1960" HREF="rfc1960.txt">RFC1960</A> +"A String Representation of LDAP Search Filters" +<BR> Updates: +<A HREF="#RFC1558">RFC1558</A> +<BR> +<LI> +<A NAME="RFC1893" HREF="rfc1893.txt">RFC1893</A> +"Enhanced Mail System Status Codes" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC1891" HREF="rfc1891.txt">RFC1891</A> +"SMTP Service Extension for Delivery Status Notifications" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC1876" HREF="rfc1876.txt">RFC1876</A> +"A Means for Expressing Location Information in the Domain Name System" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1869" HREF="rfc1869.txt">RFC1869</A> +"SMTP Service Extensions" +<BR> Updates: +<A HREF="#RFC1651">RFC1651</A> +<A HREF="#RFC1425">RFC1425</A> +<BR> +<LI> +<A NAME="RFC1706" HREF="rfc1706.txt">RFC1706</A> +"DNS NSAP Resource Records" +<BR> Updates: +<A HREF="#RFC1637">RFC1637</A> +<A HREF="#RFC1348">RFC1348</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<BR> +<LI> +<A NAME="RFC1652" HREF="rfc1652.txt">RFC1652</A> +"SMTP Service Extension for 8bit-MIMEtransport" +<BR> Updates: +<A HREF="#RFC1426">RFC1426</A> +<BR> +<LI> +<A NAME="RFC1651" HREF="rfc1651.txt">RFC1651</A> +"SMTP Service Extensions" +<BR> Updates: +<A HREF="#RFC1425">RFC1425</A> +<BR> +<LI> +<A NAME="RFC1637" HREF="rfc1637.txt">RFC1637</A> +"DNS NSAP Resource Records" +<BR> Updates: +<A HREF="#RFC1348">RFC1348</A> +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1522" HREF="rfc1522.txt">RFC1522</A> +"MIME (Multipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text" +<BR> Updates: +<A HREF="#RFC1342">RFC1342</A> +<BR> +<LI> +<A NAME="RFC1521" HREF="rfc1521.txt">RFC1521</A> +"MIME (Multipurpose Internet Mail Extensions) Part One: Mechanisms for Specifying and Describing the Format of Internet Message Bodies" +<BR> Updates: +<A HREF="#RFC1341">RFC1341</A> +<BR> +<LI> +<A NAME="RFC1428" HREF="rfc1428.txt">RFC1428</A> +"Transition of Internet Mail from Just-Send-8 to 8bit-SMTP/MIME" +<BR> Updates: +none<BR> +<LI> +<A NAME="RFC1413" HREF="rfc1413.txt">RFC1413</A> +"Identification Protocol" +<BR> Updates: +<A HREF="#RFC0931">RFC0931</A> +<A HREF="#RFC0912">RFC0912</A> +<BR> +<LI> +<A NAME="RFC1183" HREF="rfc1183.txt">RFC1183</A> +"New DNS RR Definitions" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1101" HREF="rfc1101.txt">RFC1101</A> +"DNS encoding of network names and other types" +<BR> Updates: +<A HREF="#RFC1035">RFC1035</A> +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC1035" HREF="rfc1035.txt">RFC1035</A> +"Domain names - implementation and specification" +<BR> Updates: +<A HREF="#RFC1034">RFC1034</A> +<A HREF="#RFC0973">RFC0973</A> +<A HREF="#RFC0883">RFC0883</A> +<A HREF="#RFC0882">RFC0882</A> +<BR> +<LI> +<A NAME="RFC0931" HREF="rfc931.txt">RFC0931</A> +"Authentication server" +<BR> Updates: +<A HREF="#RFC0912">RFC0912</A> +<BR> +<LI> +<A NAME="RFC0822" HREF="rfc822.txt">RFC0822</A> +"Standard for the format of ARPA Internet text messages" +<BR> Updates: +<A HREF="#RFC0733">RFC0733</A> +<A HREF="#RFC0724">RFC0724</A> +<BR> +<LI> +<A NAME="RFC0821" HREF="rfc821.txt">RFC0821</A> +"Simple Mail Transfer Protocol" +<BR> Updates: +<A HREF="#RFC0788">RFC0788</A> +<A HREF="#RFC0780">RFC0780</A> +<A HREF="#RFC0772">RFC0772</A> +<BR> +<LI> +<A NAME="RFC0788" HREF="rfc788.txt">RFC0788</A> +"Simple Mail Transfer Protocol" +<BR> Updates: +<A HREF="#RFC0780">RFC0780</A> +<A HREF="#RFC0772">RFC0772</A> +<BR> +<LI> +<A NAME="RFC0780" HREF="rfc780.txt">RFC0780</A> +"Mail Transfer Protocol" +<BR> Updates: +<A HREF="#RFC0772">RFC0772</A> +<BR> +<LI> +<A NAME="RFC0733" HREF="rfc733.txt">RFC0733</A> +"Standard for the format of ARPA network text messages" +<BR> Updates: +<A HREF="#RFC0724">RFC0724</A> +<BR> +</UL> |
